TACO

3 months 3 weeks ago #37 by snowman
Replied by snowman on topic In-game camera position display.
After deleting it, no "Locations.ini" is created. So that makes sense now.

Also, I have downloaded the program again after you updated your post and the SHIFT+X no longer works when aiming up. It seems to drop downwards at a certain angle, no matter what direction I'm aiming and using that key combination. Can you test it yourself, please?

"Walk through all fear no matter what."

Please Log in or Create an account to join the conversation.

3 months 3 weeks ago #38 by Stern
Replied by Stern on topic In-game camera position display.
I just tested it Shift+Z and Shift+X works as it should.

Anyway no changes made to Camera functions... :/

*Only changed the way program reads X / Y from Settings ini file to avoid it getting wrong values at start when no X / Y exists in settings file.

The one who hesitates is lost !
The following user(s) said Thank You: snowman

Please Log in or Create an account to join the conversation.

3 months 3 weeks ago #39 by snowman
Replied by snowman on topic In-game camera position display.
I didn't save your previous version. Can you please post that again in a reply here, without the X, Y changes. Maybe it's only in my case... at least I can test it and compare again. I'm so sure it worked before. Now I'm stuck at the Y value set using Shift + Up and it does go down, but now always. If I look straight down, it just goes in any direction, except the Y axis.

"Walk through all fear no matter what."

Please Log in or Create an account to join the conversation.

3 months 3 weeks ago - 3 months 3 weeks ago #40 by Stern
Replied by Stern on topic In-game camera position display.
Cannot add here more than 2Mb,
uploaded:
https://1drv.ms/u/s!Aj4b71jV4JhLgx6Bb6GoFvSCqMtw?e=qK9mpS
(18.12.2020 vesrion)

The one who hesitates is lost !
The following user(s) said Thank You: snowman

Please Log in or Create an account to join the conversation.

3 months 3 weeks ago - 3 months 3 weeks ago #41 by snowman
Replied by snowman on topic In-game camera position display.
Back to report! :snowman:

Tested both versions(latest one from the first post and this one attached here[older]) on different servers, different styles, with and without players.

The location of the program on my screen is saved in the Application's .ini file and every new launch opens at the location where it was last closed. So this works.

Save Camera Location function doesn't work for me. It loads the 0, 0, 0 that are already in the Locations.ini file. For some reason it works for the other .ini file.

There were some strange bugs, like game freezing when detaching camera or the program was working, but not displaying/ updating step changes and camera detachment color. Please ignore this for now. Maybe it's something on my side.

Now... everything works perfect when I'm alone on the server. When someone else is on the server and I connect I get the problem described earlier, meaning Shift + X no longer moves as normal, but sets a course/ axis of it's own, ignoring where the mouse is pointed at. It tends to go under maps. The faster the step, the faster it goes, at a very lean angle, less than 10 deg(maybe). Tested on Italy1, Ardennes 2 Liege, Ardennes 1 Tanks with and without players. When the players are there, the command gets bugged... after the players have left, it works!

Thank you for attaching the older version, it helped me pin down some issues :gj:

I must also inform you that on my system, there is the problem of driving vehicles. Sometimes it works, sometimes it's like having acceleration and break buttons pressed at the same time. No idea what is causing this. It worked on maps with and without players, and also the opposite happened. This problem I don't mind.

"Walk through all fear no matter what."

Please Log in or Create an account to join the conversation.

3 months 3 weeks ago - 3 months 3 weeks ago #42 by Stern
Replied by Stern on topic In-game camera position display.
Try it now (from original Link),
This tool was meant to be mod tool (when its used for testing alone)
It was never tested if camera functions work in server with other players...
Up / Down value got bugged when other players in server, it was pointed down.
I had a selection of addresses, tested them with 3 players in server, found one that didnt get bugged.

Locations.ini is for both, teleport and camera !

Location=teleport x/y/z
Camera=Camera x/y/z

example:

[Location2]
X=28,06
Z=0,02
Y=222,31

[Camera1]
X=-22.97
Y=5.2
Z=1.85

*Its strange if it can read and save program position on screen but cannot save camera locations...:whip:

The one who hesitates is lost !
The following user(s) said Thank You: snowman

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum

Next birthdays

  • iBeLKa birthday is in 5 days (28)
  • 43 birthday is in 8 days (54)
 
 
 

We use cookies on our website. Some of them are essential for the operation of the site, while others help us to improve this site and the user experience (tracking cookies). You can decide for yourself whether you want to allow cookies or not. Please note that if you reject them, you may not be able to use all the functionalities of the site.